TYPO3 bei all-inkl installieren

Typo3 + all-inklTypo3 bei all-inkl zu installieren, ist nicht ganz tückenfrei.
Hier daher die Zusammenfassung meiner Tests und Recherchen, die mich letztendlich doch noch zu einer laufenden Typo3-Installation auf meinem WebPrivatL-Paket gebracht haben:

1. Download
Download der ZIP-Packages dummy-4.0.zip und typo3_src-4.0.zip von der Typo3-Download-Seite

2. Entpacken
Beide Dateien in einen gemeinsamen Ordner (z.B. /cms/ ) entpacken

3. Dateien uploaden
Diesen Ordner mit allen enthaltenen Dateien in das Root-Verzeichnis des Servers laden (z.B. www.meinedomain.de) -> Ergebnis www.meinedomain.de/cms/

4. Installtool aktivieren
Das Installtool aktivieren durch auskommentieren der die()-Funktion in Zeile 45 der Datei http://www.meinedomain.de/cms/typo3/install/index.php.

Ergebnis:

43 // This checks for my own IP at home. You can just remove the if-statement.
44 if (1==0 || (substr($_SERVER['REMOTE_ADDR'],0,7)!='192.168' && $_SERVER['REMOTE_ADDR']!='127.0.0.1'))	{
45 // die("In the source distribution of TYPO3, the install script is disabled by a die() function call.<br/><b>Fix:</b> Open the file typo3/install/index.php and remove/out-comment the line that outputs this message!");
46 }

Anschließend natürlich die geänderte Datei auf den Webserver hochladen.

5. .htaccess-Datei anpassen
Die Datei http://www.meinedomain.de.de/cms/_.htaccess öffnen und in der letzten Zeile den Befehl AddHandler php-fastcgi .php .php4 einfügen.

Die letzten Zeilen sollten dann so aussehen:

# Add your own rules here
# …
AddHandler php-fastcgi .php .php4

6. _.htaccess in .htaccess umbenennen und uploaden
Die Datei anschließend von _.htaccess in .htaccess (ohne _) umbenennen und auf den Webserver laden.

7. Neue Datenbank für Typo3 anlegen
Im KAS-Bereich eine neue Datenbank für das Typo3-Projekt anlegen.

8. Installation beginnen
Die Installation von Typo3 über den Aufruf der Datei http://www.meinedomain.de/cms/typo3/install/ beginnen und den Anweisungen am Bildschirm folgen.

9. Pfad zu ImageMagick ändern
Im Typo3 Install Tool noch den Pfad zu ImageMagick ändern. Typo3 benötigt ImageMagick zur Generierung von Bildern.
Dafür den Menüpunkt “All Configuration” auswählen, zu [im_path] scrollen und den bestehenden Pfad durch /usr/bin/ ersetzen.

10. GD-Lib-Version anpassen
Ebenfalls im Menü “All Configuration” den Wert [gdlib_2] von 0 auf 1 setzen.

UPDATE 28.08.2006:

All-inkl bietet neuerdings auch eine automatische Typo3-Installation an! »


Kommentare & Trackbacks

  1. Kommentar von marc:

    Gravatar von marc

    Mich würden noch deine (kunden-)erfahrungen mit typo3 interessieren? Wir haben uns mal mit einer Vereinsseite versucht,; sind allerdings aufgrund der hohen Einarbeitung szeit von Redakteuren auf joomla! gewechselt.

  2. Kommentar von Nina:

    Gravatar von Nina

    Danke, das ist ne Spitzenanleitung. Ich habe es zwar inzwischen selbst hinbekommen, wäre damals aber über diese kleine Hilfe seeehr dankbar gewesen :-)

    Wie stabil läuft Typo3 denn bei dir auf nem All-Inkl Server? Für aufwendige Projekte mit hoher Belastung empfehle ich meinen Kunden für ne Typo-Installation inzwischen eher http://www.mittwald.de da deren Server mehr abkönnen.

  3. Kommentar von Franziska:

    Gravatar von Franziska

    Hallo Nina,
    ja, das war gar nicht so einfach …
    Hab zum Glück auch einige Hinweise im Netz gefunden.

    Typo3 ist bei all-inkl ziemlich langsam. Außerdem ist wohl nicht ganz die richtige ImageMagick-Version auf den Servern. Manche Optionen zur automatischen Bildgenerierung funktionieren da nicht ganz so optimal.

    Ich denke auch, dass für große Typo3-Projekte ein auf Typo3 spezialisierter Provider sicher die beste Wahl ist.
    Habe mir auch bei Mittwald mal einen 4-wöchigen kostenlosen Account anlegen lassen und war sehr beeindruckt von der Geschwindigkeit, mit der Typo3 dort lief.

    Ich finde übrigens Deine pro-barrierefreiheit-Seite sehr interessant!

    Und natürlich Glückwunsch zum BIENE-Award! :)

    Liebe Grüße
    Franziska

  4. Kommentar von Nina:

    Gravatar von Nina

    Freut mich, dass dir die proBF Seite gefällt :-)

    Und danke für die Glückwünsche zum Award. Ist zwar schon ne Weile her (2004), aber vielleicht wirds ja dieses Jahr wieder was :)

  5. Kommentar von Stefan Bihl:

    Gravatar von Stefan Bihl

    Interessanter Bericht. Genau die Konstellation all-inkl Typo3 habe ich gerade vor mir. Mit deiner Anleitung sollte es aber klappen.

    Gruß,
    Stefan

  6. Kommentar von Franziska:

    Gravatar von Franziska

    Na dann,

    viel Glück :)

    Franziska

  7. Kommentar von Thomas:

    Gravatar von Thomas

    Hallo,
    vielleicht hast du mir einen Tipp: Gemäß deiner Anleitung habe ich die .htaccess Datei angepasst und aktiviert.
    Doch gerade danach kann ich im Typo3-Backend keine Datei mehr in mein Verzeichnis fileadmin/bilder hochladen: Warning: move_uploaded_file(/www/htdocs/…/fileadmin/bilder/009_036_segeln_untersee.jpg) [function.move-uploaded-file]: failed to open stream: Permission denied

    Irgendeine Idee woran es liegen könnte?

    Danke.
    Thomas

  8. Kommentar von Franziska:

    Gravatar von Franziska

    Hallo Thomas,
    tut mir leid, mir fällt momentan nicht ein, woran das liegen könnte. Bei mir funktioniert das Hochladen von Dateien ganz normal.

    Viele Grüße
    Franziska

  9. Pingback: Typo3, Joomla, Wordpress und phpBB bei all-inkl automatisch installieren lassen » die Netzspielwiese:

    Gravatar von Typo3, Joomla, Wordpress und phpBB bei all-inkl automatisch installieren lassen » die Netzspielwiese

    [...] Hab\’ es noch nicht getestet, aber wenn das funktioniert, könnte man sich vor allem für die Typo3-Installation viel Fizzelarbeit sparen! [...]

  10. Kommentar von Typo3 boy:

    Gravatar von Typo3 boy

    Bei mir fukntioniert es auch soweit, wo genau liegt bei Euch das Problem!

  11. Kommentar von Typo3 girl:

    Gravatar von Typo3 girl

    Bei mit klappt es ebenfalls ohne die Warning… Meldung. Somit kann ich dir leider hier nicht weiterhelfen.

  12. Kommentar von Andreas:

    Gravatar von Andreas

    Servus, bei mir hat soweit auch alles geklappt. Mein Problem ist jedoch, dass ich wenn ich CSS_STYLED_CONTENT bei den Templates aktiviere, er mir folgende Fehlermeldung schmeisst
    Cannot find tslib/. Please set path by defining $configured_tslib_path in 0.

    Hast du das Problem auch gehabt oder nutzt du die CMS Extension beim templates erstellen nicht?

  13. Kommentar von Franziska:

    Gravatar von Franziska

    Tut mir leid, Andreas,

    ich habe nix mehr mit Typo3 zu tun.
    Es war mir zu viel Arbeit für ein CMS.

    Franziska

  14. Kommentar von Nils:

    Gravatar von Nils

    Es war ein Kampf. Außerdem gabs noch den ein oder anderen Grund einen eigenen managed Server zu holen. Nun bin ich happy und um einige “Mark” im Monat leichter. Mh. Mal schaun :)

    Gruss

Kommentar schreiben

* Pflichtfelder